Platform requirements

Windows

Operating Systems

  • Windows 7, 8, 8.1, 10 (32 and 64 bit)

 Windows 95, Windows 98, Windows ME, Windows XP, Windows Vista, Windows NT 4, Windows 2000 are no longer supported as of Release Version 4.7

  • Windows Server 2008 (32 and 64 bit)
  • Windows Server 2008 R2, 2012, 2012 R2, 2016 (64 bit)

Windows Server 2003 (including R2) are no longer supported as of Release Version 4.7

Runtime support

GDI+

Pre-installed on XP and later.

.NET

Version 2.0 or higher (only required when using the .NET interface of an API)

Unix

Operating systems

PDF Tools’ software is compiled on the following platforms.

The number of the version is intentionally kept low. As a result of that all platforms with a higher version are support due to backwards compatibility of the platform itself.

HP UX 11i and later PA-RISC2.0 (32 bit)
HP-UX 11i and later ia64 (Itanium) (64 bit)
IBM AIX 5.1 (32 and 64 bit)
Linux 2.4: RedHat (32 and 64 bit)
Linux 2.6: RedHat (64 Bit), SUSE 10 (32 bit)

macOS 10.4 - 32 and 64 bit
Sun Solaris 2.8 SPARC - 32 and 64 bit
Sun Solaris 10 x86 - 32 and 64 bit
FreeBSD 5.5 - 32 bit

Runtime support

GNU

GNU Shared libraries are required for all API products, as well as for all 64 bit products. They can be downloaded from Resources.

C++ compiler versions

The software is generated with the following compiler versions for C/C++:

Platform C/C++
Windows MSVC 14.0
macOS 10.5 x86 gcc 4.0.1
SuSE Linux/Intel 32 bit gcc 4.1.2
SuSE Linux/Intel 64 bit gcc 3.2
Redhat Linux/Intel 32 bit gcc 3.2.2
Redhat Linux/Intel 64 bit gcc 3.4
FreeBSD gcc 2.95.4
Sun Solaris 2.8/SPARC gcc 3.4.6
Sun Solaris 2.8/Intel gcc 3.4.6
IBM AIX 5.1 gcc 4.2.4
HP UX 11.i (11.23) gcc 4.1.2
HP UX 11.23 IA64 gcc 4.3.3

Java

JRE

1.6 or higher (only required when using the Java interface of an API)