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1 Introduction 

1.1 Description 

The 3-Heights™ PDF Viewer is an independent, compact, high-quality PDF viewer. It 

offers a multitude of functions such as display options, navigation, optional printing 
and support for non-PDF formats such as TIFF, JPEG and other raster image formats. 
The PDF Viewer is characterized mainly by its ease of integration and handling and 
high performance. 

The Viewer can be used as a standalone application or software solution component. 
The Viewer can be started outside of the programming environment within seconds via 
the command line. 

 

1.2 Functions  

The PDF Viewer offers many options for displaying PDF documents in a manner that 
suits requirements: files can be viewed in single page or multi-page mode, and the 

navigation supports links, bookmarks and calling up pages arbitrarily. The search 
function can locate strings of text in the document. The tool supports PDF documents 
in many languages: the reproduction of Japanese, Chinese, Korean, Russian, etc., is no 
problem at all. The PDF Viewer can also print out and save PDF documents. 
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 Viewing 

 Display PDF file in single page or multi page mode 

 Enter password to decrypt PDF documents 

 Display image files such as TIFF, JPEG, JBIG2, JPEG2000, PNG and GIF 

 Enlarge and reduce windows with the aid of a zoom rectangle or zoom factor 

 Query the number of pages in a document 

 Freely select any page in the document for display 

 Set scalability (page size, page width, actual size, any size) 

 Set various display options such as image filters 

 Reproduce documents with Chinese, Japanese and Korean fonts (CJK) 

 Double Buffering 

 Set number of pages per window 

 Replace embedded fonts with preinstalled fonts for viewing and printing 

 Display fonts as vector graphics 

 Rotate and display the page 

 Show annotations 

 Save the PDF or image files on display  

 Set user rights for the saved new version of the PDF file 

 Navigation 

 Search PDF documents for a specific string of text 

 Show and hide windows for bookmarks and page navigation 

 Jump to a bookmark's location 

 Jump to the location of a link within the document 

 Move windows vertically and horizontally using the mouse or keyboard 

 Set mouse cursor mode 

 Show and hide scrollbars 

 Activate or deactivate links 

 Printing 

 Print the PDF or image files on display to any printer 

 Set number of copies  

 Black point compensation during printing 

 Win9x compatibility mode 
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 Formats 

Input Formats 

 PDF 1.0 - 1.7, PDF/A  

 Raster images (e.g. TIFF, JPEG, PNG, GIF, BMP)   

Output Formats 

 The PDF Viewer can save files in their original input format.  

 Compliance 

Standards: ISO 32000-1 (PDF 1.7), ISO 19005-1 (PDF/A-1), ISO 19005-2 (PDF/A-2) 

 

1.3 Operating Systems 

Windows 2000, XP, 2003, Vista, 2008, Windows 7, 2008-R2 - 32 and 64 bit 

1.4 Compatibility Note 

In versions prior to 2010 it was distinguished between the standard and the pro 
version. Certain features (such as printing or viewing raster images) were only 
supported in the pro version. At present there is only one version, which supports all 
features. 
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2 Installation 

2.1 Installing the PDF Desktop Viewer 

1. Download the ZIP archive of the product from your download account at 

www.pdf-tools.com. 

2. Open the ZIP archive. 

3. Check the appropriate option to preserve file paths (folder names) and unzip the 
archive to a local folder (e.g. C:\program files\pdf-tools\). 

4. The unzip process now creates the following subdirectories: 

 Bin: Contains the runtime executable binary code. A required file is the 
gdiplus.dll, which must be on the environment variable "Path". 

 Bin\Fonts: Contains the fonts Symbol and ZapfDingbats.  

 Bin\Icc: These are links to download color profiles. The color profiles are 
optional, but it is suggested to download them. Once downloaded, the CMYK 
color profile must be named CMYK.icc and the RGB color profile must be 
named sRGB.icm. Both color profiles must reside in the directory bin\Icc\. 

 Doc: Contains documentation files. 

5. Copy and thereby install the two fonts Symbol and ZapfDingbats to the fonts 
directory of Windows (%systemroot%\fonts, e.g. C:\Windows\fonts) using 
Windows Explorer. 

6. (Optional) Make a shortcut from the executable file viewer.exe to your desktop.  

7. (Optional) If you want to be able to start the viewer from a shell, the directory 
where the file viewer.exe resides needs to be included in the environment 
variable "Path".  

 How to set the Environment Variable "Path" 

To set the environment variable on "Path" 

Windows 2000, go to Start -> Settings -> Control Panel -> System -> Advanced 

-> Environment Variables 

Windows XP and later, go to Start -> Control Panel (classic view) -> System -> 
Advanced -> Environment Variables. 

Select "Path" and Edit, then add the directory where viewer.exe is located to the 
"Path". If the environment variable "Path" does not exist, create it. 
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3 Getting started and User’s Guide 

3.1 Starting the PDF Desktop Viewer 

To start the 3-Heights™ PDF Desktop Viewer, either double click the icon or type 

viewer in the shell. 

C:\> Viewer 

This will open the Viewer, that looks like the image below: 

 

3.2 File 

 Open 

Open a PDF document for viewing. The Pro version provides the feature to open 

various raster images formats: BMP, GIF, JBIG, JPEG, JPEG2000, PNG, TIFF 
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When using a shell, a PDF file name can optionally be provided as argument. Allowed 
are relative and absolute paths. 

Start the 3-Heights™ PDF Viewer form the shell and directly open the document 
“mydocument.pdf”. 

C:\> viewer mydocument.pdf 

The file path can be absolute: 

C:\> viewer C:\myFiles\mydocument.pdf 

Menu File -> Open 

Shortcut Ctrl O 

Icon  

 Close 

Close the currently being viewed document (if any). 

Menu File -> Close 

Shortcut none 

Icon none 

 Printing 

(Pro Version only) 

The 3-Heights™ Viewer Desktop has the functionality to print the currently opened 
document. 

Menu File -> Print 

Shortcut Ctrl P 

Icon  

 Exit 

Exit the application. 

Menu File -> Exit 

Shortcut Ctrl X 

Icon none 

3.3 Document 

To navigate through the pages of a PDF documents, use the arrows icons from the 
toolbar to go to the first, the previous, the next or the last page. 

Alternatively use the Menu Document for the same functions and additionally the 

function Goto page to select a page number directly. 
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 First Page 

Go to the first page of the document. 

Menu Document –> First Page 

Shortcut Ctrl Shift PageUp 

Icon  

 Previous Page 

Go to the previous page of the page that is currently displayed. If currently the first 
page is displayed, the page does not change. 

Menu Document -> Previous Page 

Shortcut Ctrl PageUp 

Icon  

  Next Page 

Go to the next page of the page that currently displayed. If currently the last page is 
displayed, the page does not change. 

Menu Document -> Next Page 

Shortcut Ctrl PageDown 

Icon  

 Last Page 

Go to the last page of the document. 

Menu Document -> Last Page 

Shortcut Ctrl Shift PageDown 

Icon  

 Go to Page 

Go to a page within the current document. 

Calling this menu launches the dialog box shown in the 
screenshot to the right. 

The dialog is modal and closes after pressing either of the 

buttons or the enter key.  

 

Menu Document -> Go to Page 

Shortcut Ctrl N 

Icon none 
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 Scroll in Page 

Use the icon with the white hand to scroll a page up and down. 

Menu Document -> Previous Page 

Shortcut Ctrl Shift PageDown 

Icon  

 

3.4 Search 

 Search 

To find a sting in the PDF document, choose the command Search form the menu 
Search. This will pop up a dialog asking for the search string.  

The search string may not contain blanks. An asterix (*) for wildcards is not necessary. 

 
Menu Search -> Search 

Shortcut Ctrl F 

Icon none 

 Search Next, Previous 

To get the next occurrence of a string previously searched for use the command 
Search next. 

Menu Search -> Search next 

Shortcut Ctrl G 

Icon none 

 Highlighting 

Selecting the highlighting feature opens the highlighting dialog in the left hand side of 
the viewer. The dialog allows for searching different texts and marking them in 
different colors. 

Use Ctrl-G to find the next instance of the marked text, use Ctrl-Shift-G for the 
previous. 
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3.5 View 

 Zoom in, Zoom out 

To zoom in and out, use the corresponding options in the Menu View or the +/- icons. 
One click zooms in/out by 10%. 

Menu View -> Zoom In, Zoom Out 

Shortcut Ctrl +, Ctrl – 

Icon ,  

 Fit Window 

Resize the displayed page so that the page width and the page height fit inside the 
give frame size of the viewer. 

Menu View -> Fit Window 

Shortcut Ctrl 0 

Icon  

 Actual Size 

Display the page at 100% zoom. 

Menu View -> Actual Size 

Shortcut Ctrl 1 

Icon  

 Fit Width 

Resize the displayed page so that the page width matches the width of the frame of 
the viewer. 

Menu View -> Fit Width 

Shortcut Ctrl 2 

Icon  

 Zoom to Window 

Click on the icon with the white arrow, then click on the PDF, draw an area and the 
Viewer zooms to this area. 

Menu none 

Shortcut none 

Icon  
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 View Outlines 

Disable/Enable the outlines (bookmarks) at the left hand side of the viewer. This 
setting disables “View Page List”. 

Menu View -> View Outlines 

Shortcut Ctrl B 

Icon none 

 View Page List 

Disable/Enable the page list (page 1, page 2, page 3, etc.) at the left hand side of the 
viewer. This setting disables “View Outlines”. 

Menu View -> View Page List 

Shortcut none 

Icon none 

 Double Buffer 

Disable/Enable double buffering. 

Double buffering is a technique used to minimize visible artifacts from the drawing 
process (flickering). As opposed to single buffering, the memory used for the displayed 
page is kept separately for writing and reading. This results in a better viewing quality 
but also requires more memory and CPU. 

Menu View -> Double Buffering 

Shortcut none 

Icon none 

 Scrollbars 

Disable/Enable horizontal and vertical scrollbars. 

Menu View -> Scrollbars 

Shortcut none 

Icon none 

 Page Layout <> Document Layout 

Choose between the page and document layout. The page layout displays one page at 
a time (or two pages at time if selected from the menu Extras -> Viewing Options -> 
Two Pages per Window. In the document layout pages are continuous in vertical order. 

The default is the document layout. 

Menu View -> Page Layout 

View -> Document Layout 
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Shortcut none 

Icon none 

 

 

3.6 Extras 

 Accurate Rendering Mode (default) 

There are two modes: Accurate (checked) and fast (not checked). The accurate mode 
uses various image filters and the GDI+. It is slower but provides a better image 
quality. 

Menu Extras -> Viewing Options -> Accurate Rendering Mode 

Shortcut none 

Icon none 

 Page per Window 

This option sets the number of pages per window to one or two. 

The default is one page per window. 

Menu Extras -> Viewing Options -> One page per window 

Extras -> Viewing Options -> Two pages per window 

Shortcut none 

Icon none 

 Win9x Compatibility 

Run in Windows 9x compatibility mode. Setting this option can resolve issues with 
nested transformation matrices which are not supported by all printing devices. 

Menu Extras -> Viewing Options -> Win9X Compatibility 

Shortcut none 

Icon none 

 Use Pre-Installed Fonts 

If enabled, embedded fonts are not used and are replaced by fonts installed on the 
system (in %Systemroot%\Fonts, e.g. C:\Windows\Fonts). 

Menu Extras -> Font Options -> Use Pre-Installed Fonts 

Shortcut none 
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Icon none 

 Convert to TrueType 

This item enables or disables the conversion of embedded fonts to the TrueType format 
before using the font for rendering. This item is mainly used for diagnostic purposes. 

Menu Extras -> Font Options -> Convert to TrueType 

Shortcut none 

Icon none 

 Convert to Outline 

This option converts fonts to outlines (vector graphics) before rendering. This item is 
mainly used for diagnostic purposes. 

Menu Extras -> Font Options -> Convert to Outline 

Shortcut none 

Icon none 

 Do Not use Embedded Fonts 

This item enables or disables the replacement of embedded fonts with installed fonts. 
This item is mainly used for diagnostic purposes. 

Menu Extras -> Font Options -> Don’t use embedded fonts 

Shortcut none 

Icon none 
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3.7 Help 

 Info  

Retrieve the copyright note and version number of your viewer. 

  

Note that this only lists the major version. In order to retrieve the full version number, 
right-click the executable viewer.exe or and select the menu “Properties”. In the 
“Properties” window select the tab “Version”. 

 

Menu Help -> Info… 

Shortcut Ctrl ? 

Icon  
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4 Tips, Tricks and Troubleshooting 

4.1 How to Use/Change the Color Profiles 

The 3-Heights PDF Rendering Engine works in the RGB color space. For color 
conversions, the two color profiles in the folder Icc/ are used. Color profiles can be 
downloaded from the links provided in the directory Icc/. The color profiles that are 
named CMYK.icc and sRGB.icm are applied. 

In order to change the current color profile, overwrite these two color profiles with new 
color profiles. 

If no color profile is available, the conversion is done algorithmically. 

4.2 Typing viewer Does Not Start the PDF Viewer 

Make sure the directory with the file viewer.exe is included in the "Path" environment 
variable. A reason for this to happen is when the viewer.exe is moved to another 
directory. 

4.3 Performance 

The 3-Heights™ PDF Viewer provides a variety of settings to tune the performance. In 
most cases a simple rules applies: Higher quality takes more resources (memory, CPU) 

and therefore lowers the performance. 

The following settings have an impact on the performance: 

 Content of the PDF: A document with thousands of objects requires more time 
for rendering then a page with plain text. 

 Resolution: The higher the size of the viewer window the more pixel need to be 
drawn and the lower the performance. 

 Double Buffering: Enabling double buffering requires extra memory and CPU. 

 Rendering Mode: Disabling the accurate rendering mode improves the 
performance at the cost of visual quality. It should only be applied at high zoom 
levels. 

4.4 Text Is Not Displayed as Expected 

 Font Replacement Strategy 

This section describes the exact behavior of font handling of the rendering engine 2.0. 
It is rather technical and it is not required to be understood in order to properly use 
the software. 
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The following steps are performed sequentially in the search of a font. If a font is 
found, the search is stopped; otherwise the next step is performed. 

1. If “Outlines” is enabled, and the font is embedded, outlines1 are applied 

2. If the font is not embedded or “Use pre-installed fonts” is set: 

a.the substitution from the [Replace] section in the configuration file 

“fonts.ini” is executed and the fonts directory is searched 

b. it is verified if it is a standard font2 and the fonts directory is searched 

c. the substitution from the [Fonts] section in the configuration file “fonts.ini” 

is executed and the fonts directory is searched 

d. the “Italic” and “Bold” of the font is ignored and the fonts directory is 

searched 

3. If the font is embedded and “Don’t not use embedded fonts” is set and the font 

does not have Unicodes, outlines are applied 

4. If the font is embedded and “Don’t not use embedded fonts” is not set, the 

embedded font is used 

5. If “Don’t not use embedded fonts” is not set and the font has Unicodes, the 

nearest pre-installed3 font is tailored and used 

6. In other cases the nearest pre-installed font is used 

 Using the Font Mapping File fonts.ini 

“fonts.ini” is a configuration file to map fonts used in the PDF to fonts pre-installed on 
the system. The mapping file must reside a directory called “Fonts”, which must be a 
direct sub-directory of where the main DLL or executable resides. 

The mapping file is optional. It consists of two sections: [fonts] and [replace]. 

Both sections are used to map fonts in the PDF to fonts pre-installed on the system. 
This comes into play when the font in the PDF document does not have an embedded 
font program, or the embedded font is not used explicitly (“Don’t not use embedded 
fonts”). 

The mapping only works if the font types of the specified fonts are matching; e. g. if 
the font in the PDF is a symbolic font, such as “Symbol” or “ZapfdingBats”, the mapped 
font must be symbolic too. 

The section [fonts] is only considered if the font-matcher does not find an appropriate 
font amongst the existing pre-installed fonts. It is suggested to only use this section. 

                                         
1  text is not displayed using a font, instead it is transformed into a vector graphic representing 
the shape of the text 

2  e. g. Times−Roman, Helvetica, Courier 

3  a font that is installed on the operating system 
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The section [replace] is stronger and applied before the font-matcher. This means a 
font will be replaced as defined, even if the correct pre-installed font is available on the 
system. 

Syntax 

The syntax of the mapping file is this: 

[fonts] 

PDF_font_1=installed_font_1, {font_style} 

PDF_font_2=installed_font_2, {font_style} 

[replace] 

PDF_font_n=installed_font_n, {font_style} 

 

PDF_font_* is the name of the font in the PDF. This name can be found in one of the 
following ways: 

 Use any tool that can list fonts, such as 3-Heights PDF Extract or 3-Heights PDF 

Optimization. Ignore possible prefixes of subset fonts. A subset prefix consists 

of 6 characters followed by the plus sign. For example 

"KHFOKE+MonotypeCorsiva", in this case only use "MonotypeCorsiva" as font 

name in the mapping file. 

 Open the document with Adobe Acrobat, use the "MarkUp Text Tool" , mark 

the text of which you would like to know the font name, right-click it, select 

"Properties…" 

installed_font_* is the font family name of the pre-installed font. To retrieve this 
name, find the font in the Windows’ font directory and open it by double-clicking. The 
first line in the property window displays the font family name (this may vary 
depending on the operating system). The font family name does not include font 

styles; so an example of a font family name is “Arial”, but not “Arial Italic”. 

font_style is an optional style, that is added coma-separated after the font family 
name. The style is always one word. Examples of font styles are “Italic”, “Bold”, 
BoldItalic”. 

Example 

[fonts] 

Ryumin-Light=MS Mincho 

GothicBBB-Medium=MS Gothic 

[replace] 

ArialIta=Arial, BoldItalic 

http://www.pdf-tools.com/pdf/pdf-extract-content-metadata-text.aspx
http://www.pdf-tools.com/pdf/pdf-optimization-reduce-size.aspx
http://www.pdf-tools.com/pdf/pdf-optimization-reduce-size.aspx
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4.5 Transparency 

The 3-Heigths™ rendering engine supports transparency functions such as a number of 
blend modes as well as isolated and non-isolated transparency groups, but not 
transparency in general. 
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