Plattform Voraussetzungen

Windows

Betriebssysteme

  • Windows 7*
  • Windows 8*
  • Windows 8.1*
  • Windows 10*

* 32 und 64 bit

Windows 95, Windows 98, Windows ME, Windows XP, Windows Vista, Windows NT 4, Windows 2000 werden ab Release Version 4.7 nicht mehr unterstützt.

  • Windows Server 2008 – 32 / 64 bit
  • Windows Server 2008 R2**
  • Windows Server 2012**
  • Windows Server 2012 R2**

** 64 bit

Windows Server 2003 (inklusive R2) werden ab Release Version 4.7 nicht mehr unterstützt.

Laufzeit Unterstützung

GDI+

GDI+ ist vorinstalliert auf Windows XP und neuer.

.NET

Falls Sie die .NET Schnittstelle unserer Programmierkomponenten verwenden möchten, so muss .NET 2.0 oder höher installiert sein.

Unix

Betriebssysteme

Die Software von PDF Tools wir auf folgenden Systemen produziert und bereitgestellt.

Die Versionsnummern sind absichtlich tief gehalten. Als Folge davon läuft sie auch auf allen neueren Plattformen bedingt durch die Rückwärtskompatibilität der Plattform selber.

HP UX 11i 32 bit
IBM AIX 5.1 32 und 64 bit
Linux 2.4: RedHat 32 und 64 bit
Linux 2.6: RedHat 64 Bit, SUSE 10 32 bit

Mac OS X 10.5 - 32 und 64 bit
Sun Solaris 2.8 SPARC - 32 und 64 bit
Sun Solaris 10 x86 - 32 und 64 bit
FreeBSD 5.5 - 32 bit

Laufzeit Unterstützung

GNU

GNU Shared Libraries sind eine Voraussetzung für alle API Produkte und die 64 Bit Versionen sämtlicher Produkte. Sie können von folgendem Link heruntergeladen werden: Ressourcen.

C++ Kompiler Versionen

Die Software wird aktuelle mit folgenden Kompiler Versionen erstellt:

Plattform C/C++
Windows WIN32 MSVC 8.0
Windows x64 MSVC 8.0
MAC OS/X PowerPC gcc 2.95.2
MAC OS/X 10.5 x86 gcc 4.0.1
SuSE Linux/Intel 32 bit gcc 4.1.2
SuSE Linux/Intel 64 bit gcc 3.2
Redhat Linux/Intel 32 bit gcc 3.2.2
Redhat Linux/Intel 64 bit gcc 3.4
FreeBSD gcc 2.95.4
Sun Solaris 2.8/SPARC gcc 3.4.6
Sun Solaris 2.8/Intel gcc 3.4.6
IBM AIX 5.1 gcc 4.2.4
HP UX 11.i (11.23) gcc 4.1.2
HP UX 11.23 IA64 gcc 4.3.3

Java

JRE

Für die Verwendung der Java Schnittstelle unserer APIs ist Java 1.4 oder höher vorausgesetzt.
Für das Beispiel des Java Document Viewers braucht es Java 1.5 oder höher